Hide Title bar of TotalCross application on Wayland

Hi,

After being able to load my application on boot, I’m now seeing that it’s not “fully full-screen”.
I can remove the panel from Weston by adding the following lines at /etc/xdg/weston/weston.ini:

[shell]
panel-position=none

But that is not enough to remove the title bar of the TotalCross application.

See:

My environment:

Best regards,
André Curvello

Have you tryed changing the global variable TC_FULLSCREEN=1 ?

Hi @VicMisael,

When setting TC_FULLSCREEN=1, the behavior is as shown in the picture below:

Try to run using the following arguments /scr 0,0,(width), (height)

Hi @VicMisael,

It did not worked, the behavior still the same.

Best regards,
André Curvello

Any news about this topic, @VicMisael?

Any news about this topic, @VicMisael?

Hello @andrecurvello, We found out it’s an SDL issue with Wayland, we are going to reproduce your ambient and debug this SDL issue